This PR proposes a variety of modernisations to the `jdk.sctp` module. During the fix of https://bugs.openjdk.org/browse/JDK-8296024, several improvement areas were identified including:
* Replacing duplicate code segments * Making certain fields final * Using enhanced switch * Using records * Fixing typos * Marking fields participating in serialisation with `@Serial` * Modernizing toString() implementations * Using pattern matching * Using diamond operators ------------- Commit messages: - Modernize module jdk.sctp Changes: https://git.openjdk.org/jdk/pull/11418/files Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=11418&range=00 Issue: https://bugs.openjdk.org/browse/JDK-8297778 Stats: 609 lines in 31 files changed: 102 ins; 176 del; 331 mod Patch: https://git.openjdk.org/jdk/pull/11418.diff Fetch: git fetch https://git.openjdk.org/jdk pull/11418/head:pull/11418 PR: https://git.openjdk.org/jdk/pull/11418