Hi,

On 05/04/2016 04:12 PM, Yasumasa Suenaga wrote:
Hi Marcus,

93 out->print("filecount=%u,filesize=" SIZE_FORMAT "%s ", _file_count, byte_size_in_proper_unit(_rotate_size), proper_unit_for_byte_size(_rotate_size));

Thanks, I applied it to new webrev:

  http://cr.openjdk.java.net/~ysuenaga/JDK-8153074/webrev.03/

Looks OK.

Thanks,
Marcus


Could you review again?


Yasumasa


On 2016/05/04 22:35, Marcus Larsson wrote:
Hi,


On 05/04/2016 02:59 PM, Yasumasa Suenaga wrote:
Hi Marcus,

Thank you for your comment.

  http://cr.openjdk.java.net/~ysuenaga/JDK-8153074/webrev.02/

Looks better. The format for _rotate_size should be SIZE_FORMAT.

While we're at it I think it would be good (as I mentioned) to use a proper unit for the filesize. Basically changing

93 out->print("filecount=%u,filesize=%lu ", _file_count, _rotate_size);

into

93 out->print("filecount=%u,filesize=" SIZE_FORMAT "%s ", _file_count, byte_size_in_proper_unit(_rotate_size), proper_unit_for_byte_size(_rotate_size));


Thanks,
Marcus


I fixed to use _rotate_size and _file_count directly to show VM.log list jcmd. I do not store option string, and I added new function to print option string.

Could you review it again?


Thanks.

Yasumasa


On 2016/05/04 18:33, Marcus Larsson wrote:
Hi,


On 05/03/2016 01:43 PM, Yasumasa Suenaga wrote:
PING: Could you review and sponsor it?

http://cr.openjdk.java.net/~ysuenaga/JDK-8153074/webrev.01/

I would prefer to generate the option string from the actual options rather than saving the string from when it was configured. This would also produce/print the options for outputs that are using the defaults (which is not the case now). The filesize option could then use byte_size_in_proper_unit and proper_unit_for_byte_size to make it easier to read.

Also, get_option_string() should just be called option_string().

Thanks,
Marcus


This patch makes to show option string of LogFileOutput.


Thanks,

Yasumasa


On 2016/04/19 22:55, Yasumasa Suenaga wrote:
I adapted changes to jdk9/hs/hotspot repos.

http://cr.openjdk.java.net/~ysuenaga/JDK-8153074/webrev.01/

Please review.


Yasumasa


On 2016/04/18 23:09, Yasumasa Suenaga wrote:
PING:

I've sent review request for JDK-8153074.
Could you review it?

http://cr.openjdk.java.net/~ysuenaga/JDK-8153074/webrev.00/

If this patch is merged, user can confirm output option via VM.log jcmd.


Please review and sponsor it.


Thanks,

Yasumasa


On 2016/04/11 18:29, Yasumasa Suenaga wrote:
PING: Could you review and sponsor it?

http://cr.openjdk.java.net/~ysuenaga/JDK-8153074/webrev.00/


Thanks,

Yasumasa


On 2016/03/31 22:35, Yasumasa Suenaga wrote:
CC'ed to serviceability-dev.

Could you review it?

http://cr.openjdk.java.net/~ysuenaga/JDK-8153074/webrev.00/


Thanks,

Yasumasa


On 2016/03/30 23:09, Yasumasa Suenaga wrote:
Hi all,

This request review is related to [1].

I want to see output option (filecount, filesize) in VM.log jcmd.

     Output sample:
#2: gc.log gc=trace, filecount=5,filesize=1048576 time,level,

I uploaded webrev. Could you review it?

http://cr.openjdk.java.net/~ysuenaga/JDK-8153074/webrev.00/


I cannot access JPRT. So I need a sponsor.


Thanks,

Yasumasa


[1] http://mail.openjdk.java.net/pipermail/hotspot-runtime-dev/2016-March/018704.html





Reply via email to