On Wed, 11 Jan 2023 10:05:33 GMT, Stefan Karlsson <stef...@openjdk.org> wrote:
> I'm happy to see this flag getting removed. I'm less happy about seeing > usages of the array allocators being replaced by macros. I'd rather see an > effort towards getting rid of these macros. Could we limit this patch to only > remove the ArrayAllocatorMallocLimit flag and ArrayAllocator class, and defer > the discussion around what API to use for array allocations? `ArrayAllocator` with `ArrayAllocatorMallocLimit` removed is effectively `MallocArrayAllocator`. Are you suggesting leaving `MallocArrayAllocator` and `MmapArrayAllocator` thus update references to `ArrayAllocator` to be `MallocArrayAllocator`? As far as APIs, the majority of the codebase uses the macros. IMO consistency would be better and having two ways of doing things doesn't help. But if you feel strongly about it, we can punt and just surgically remove the bare minimum, assuming you clarify your expectation (see above). ------------- PR: https://git.openjdk.org/jdk/pull/11931