On Mon, 6 May 2024 09:12:47 GMT, Albert Mingkun Yang <[email protected]> wrote:
>> src/hotspot/share/gc/serial/serialHeap.cpp line 461:
>>
>>> 459: if (should_verify && VerifyBeforeGC) {
>>> 460: prepare_for_verify();
>>> 461: Universe::verify("Before GC");
>>
>> May the prefix of the verification log be better to specify the minor or
>> full GC? Such as `Before Minor GC` here.
>
> Other `Universe::verify("` seems to not distinguish minor/major.
OK. If someone want to change all of them in the future, she/he can file
another ticket to follow up.
>> src/hotspot/share/gc/serial/serialHeap.cpp line 463:
>>
>>> 461: Universe::verify("Before GC");
>>> 462: }
>>> 463: gc_prologue(false);
>>
>> The parameter `full` of the method `SerialHeap::gc_prologue` doesn't been
>> used. Seems a leftover of
>> [JDK-8323993](https://bugs.openjdk.org/browse/JDK-8323993).
>
> True; can probably fixed in a followup cleanup.
Filed https://bugs.openjdk.org/browse/JDK-8331723 to follow up.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/19056#discussion_r1590915891
PR Review Comment: https://git.openjdk.org/jdk/pull/19056#discussion_r1590915740