`ClassFile::transform` was initially `ClassModel::transform`, which transforms 
the receiver class model to a new class byte array. This functionality was in 
parallel with `ClassBuilder::transform`, which accepts a `ClassModel` and a 
`ClassTransform` and forwards the results to the receiver builder.

After the `ClassFile` context object introduction, `ClassModel::transform` 
becomes `ClassFile::transform`; now, its role is more similar to 
`ClassBuilder::transformMethod`, `ClassBuilder::transformField`, or 
`MethodBuilder::transformCode` (transforming subtypes), and it is confusing 
with `ClassFileBuilder::transform` (which accepts the same model type as the 
built type). We should rename `ClassFile::transform` to 
`ClassFile::transformClass` to make this method's role more clear.

This is separate from #19928 as this has much more user impact.

-------------

Commit messages:
 - Doc typo
 - Missed 3 files
 - ClassFile.transform -> transformClass

Changes: https://git.openjdk.org/jdk/pull/19952/files
  Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=19952&range=00
  Issue: https://bugs.openjdk.org/browse/JDK-8335290
  Stats: 177 lines in 58 files changed: 2 ins; 5 del; 170 mod
  Patch: https://git.openjdk.org/jdk/pull/19952.diff
  Fetch: git fetch https://git.openjdk.org/jdk.git pull/19952/head:pull/19952

PR: https://git.openjdk.org/jdk/pull/19952

Reply via email to