On Tue, 30 Jul 2024 20:11:03 GMT, Alex Menkov <amen...@openjdk.org> wrote:

>> "Attach fails" scenarios (debuggee starts listening and debugger is expected 
>> to fail trying to attach) sometimes interfere with other JDI tests (so 
>> JdwpNetProps.java test or other JDI test or both fail).
>> The fix disables the scenarios to remove noise in the CI.
>
> Alex Menkov has updated the pull request incrementally with one additional 
> commit since the last revision:
> 
>   add sys.prop to enable negative testing

test/jdk/com/sun/jdi/JdwpListenTest.java line 54:

> 52:     // It's off by default as it causes test time increase and test 
> interference (see JDK-8231915).
> 53:     private static boolean allowNegativeTesting =
> 54:         
> "true".equalsIgnoreCase(System.getProperty("JDI_ALLOW_NEGATIVE_TESTING"));

That seems a strange name for a system property - it would normally be 
something like jdk.jdi.allowNegativeTesting. Is this style of naming being used 
elsewhere?

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/20362#discussion_r1698399300

Reply via email to