On Mon, 6 Jul 2026 12:18:49 GMT, Coleen Phillimore <[email protected]> wrote:
>> src/hotspot/os/posix/attachListener_posix.cpp line 207:
>>
>>> 205: os::get_temp_directory(),
>>> os::current_process_id());
>>> 206: return -1;
>>> 207: }
>>
>> Suggestion:
>>
>> else {
>> log_warning(attach)("Failed to create temporary file for attach
>> %s/.java_pid%d: file name is too long",
>> os::get_temp_directory(), os::current_process_id());
>> return -1;
>> }
>
> No, this isn't right. The code above appends .tmp to the name, so we need to
> check 'n' after that.
Oops. Sorry missed that.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/31407#discussion_r3532799564