On Mon, 24 Aug 2026 07:08:22 GMT, Axel Boldt-Christmas <[email protected]> wrote:
>> I agree we should probably fold `metadata` into `hash` functions and rename >> and retype the field to be `intptr_t _hash` a bit more churn but feels like >> we do not benefit from this abstraction anymore. > > Separate but would also be nice to migrate the object monitors to Atomic. Yes, file another RFE to migrate to Atomic. Why is _metadata atomic? ------------- PR Review Comment: https://git.openjdk.org/jdk/pull/32471#discussion_r3843656446
