: 
http://localhost:8080/q=...&fl=StaticField1,StaticField2,%22s_Dynamic+Field+1%22
:
: I am guessing that Solr is parsing "s_Dynamic", "Field", and "1" as
: separate fields. Does anyone know a way around this? My initial testing

This is because the fl param does some pattern splitting to figure out the
names of the fields.  space "," and "|" are all considered delimiters in
the "fl" param ... it goes back to when Solr didn't have multi-value
params ... now that it does, we could say that specifying multiple fl
params means that each param is treated as an exact field name, but i
think in the common case people would still wnat some splitting to happen
... consider the case of having a "default" fl as well as an "appends"
list containing score, so you ensure people allways get it -- but you
still want them to be able to type fl=a,b,c instead of fl=a&fl=b&fl=c.

if someone wants to submit a patch to make fl multivalue, and add a new
config block to solrconfig.xml with info on parsing field names from
params, i would totally be on board that ... in addition to a
"spiltPattern" (which could be unspecificed being no spliting) this would
be a good place to specify what field alias to use for the "score" (if you
want to call it something else) and what field alias people should use if
they want raw index order when sorting (something else that was brought up
recently)

: shows that I have a similar problem if I query by that field as well. I
: was hoping that Solr would interpret text enclosed by quotes as a single
: field, but this does not appear to be the case.

: facet.query also fails. So, perhaps this is a Lucene issue?

on the query side this would definiltey be a QueryParser issue ... i'm not
sure what exactly QueryParser consideres legal field name characters, but
it certianly doesn't include spaces ... you've have to heck the
QueryParser.jj file.

(I think it's sae to say that the Lucene Java community wouldn't turn down
a patch to the querysyntax doc clarifying what rules QueryParser enforces
for field names)




-Hoss

Reply via email to