Thanks Ron! It does! On Thu, Sep 23, 2021 at 2:25 AM Ron Bonica <[email protected]> wrote:
> Dhruv, > > > > Thanks for you review and support. > > > > Does the change below (inline) address your first comment? > > > > Ron > > > > > > Juniper Business Use Only > > *From:* spring <[email protected]> *On Behalf Of *Dhruv Dhody > *Sent:* Monday, September 20, 2021 12:56 PM > *To:* [email protected] > *Cc:* [email protected] > *Subject:* Re: [spring] WG Adoption call - > draft-srcompdt-spring-compression-requirement - > draft-srcompdt-spring-compression-analysis > > > > *[External Email. Be cautious of content]* > > > > Hi, > > > > I support the adoption of both documents. > > > > Thanks for all the effort put in by everyone involved. Few minor comments > - > > > > *draft-srcompdt-spring-compression-requirement-07* > > > > In section 1 > > It is a goal of the design team to identify solutions to… > It is also a goal of the design team to consider proposals… > The design team will produce a separate document… > > Should we still need to mention the design team in the introduction? If > some history needs to be maintained, let's put that in the appendix! > > [RB] > > OLD> > > The SPRING working group defined SRv6, with [RFC8402] describing how the > Segment Routing (SR) architecture is instantiated on two data-planes: SR > over MPLS (SR-MPLS) and SR over IPv6 (SRv6). SRv6 uses a routing header > called the SR Header (SRH) [RFC8754] and defines SRv6 > > SID behaviors and a registry for identifying them in [RFC8986]. SRv6 is a > proposed standard and is deployed today. > > The SPRING working group has observed that some use cases, such as strict > path TE, may require long SRv6 SID lists. There are several proposed > methods to reduce the resulting SRv6 encapsulation size by compressing the > SID list. > > The SPRING working group formed a design team to define requirements for, > and analyze proposals to, compress SRv6 SID lists. > > It is a goal of the design team to identify solutions to SRv6 SID list > compression that are based on the SRv6 standards. As such, this document > provides requirements for SRv6 SID list compression solutions that utilize > the existing SRv6 data plane and control plane. > > It is also a goal of the design team to consider proposals that are not > based on the SRv6 data plane and control plane. As such, this document > includes requirements to evaluate whether a compression proposal provides > all the functionality of SRv6 (section "SRv6 Functionality") in addition to > satisfying compression specific requirements. > > For each requirement, a description, rationale and metrics are described. > > The design team will produce a separate document to analyze the proposals. > > This document is a draft; additional requirements are under review, > additional requirements will be added, and current requirements may > change. Appendix A contains a subset of requirements without unanimous > consensus. Additional requirements without unanimous consensus are not in > the appendix. > > <OLD > > NEW> > > The Segment Routing (SR) architecture [RFC 8402] can be instantiated on > two data-planes: SR over MPLS (SR-MPLS) and SR over IPv6 (SRv6). SRv6 uses > a routing header called the SR Header (SRH) [RFC8754] and defines SRv6 SID > behaviors and a registry for identifying them in [RFC8986]. SRv6 is a > proposed standard and is deployed today. > > Some use cases, such as strict path TE, may require long SRv6 SID lists. > There are several proposed methods to reduce the resulting SRv6 > encapsulation size by compressing the SID list. > > This document defines requirements for a SID list compression mechanism. > For each requirement, a description, rationale and metrics are provided. > > A companion document [draft-srcompdt-spring-compression-analysis] > evaluates several compression mechanisms according to compliance with the > requirements described by this document. > > <NEW > > [RB] > > > >
_______________________________________________ spring mailing list [email protected] https://www.ietf.org/mailman/listinfo/spring
