On Tue, Aug 01, 2017 at 10:56:47AM -0700, Matt Chambers wrote: > load_extension() has the very sensible behavior of: > > So for example, if "samplelib" cannot be loaded, then names like > > "samplelib.so" or "samplelib.dylib" or "samplelib.dll" might be tried > > also. > > I would like to see that extended to include "libsamplelib.so" since that is > the default naming scheme on many *nix platforms. This simple change would > allow me to use the same base library name for my extension on both Windows > and Linux. Otherwise I have to modify my build system to override its > default behavior of adding the lib prefix on Linux.
You're mistaken. lib<name>.so is NOT "the default naming scheme on many *nix platforms". lib<name>.so is the naming scheme when you want the link-editor (e.g., ld(1)) to find a library using -l<name>. But loadable modules are almost never meant to be used that way. They're usually meant to be used only through dlopen() and friends. Nico -- _______________________________________________ sqlite-users mailing list sqlite-users@mailinglists.sqlite.org http://mailinglists.sqlite.org/cgi-bin/mailman/listinfo/sqlite-users