On 01/20/2017 09:41 AM, FUSTE Emmanuel wrote:
> Le 20/01/2017 à 16:36, Alex Rousskov a écrit :
>> 1. Rename notnulldelim to a positive name like haveDelimiter or, better,
>> remove that variable completely in favor of a direct *delimiter test.
>>
>> 2. Use a *delimiter test instead of strcmp("") to detect empty delimiter
>> strings.
>>
>> 3. Rephrase the -l help string to use "empty string" instead of "null"
>> and "password alone" instead of "no realm" (or similar).


> Is the attached v2 address all your points ?

Thank you for adjusting your patch! You are still overcomplicating the
delimiter test (my item #2) AFAICT. I suggest removing nulldelimiter
variable and simply replacing

  if (encrpass && (*delimiter != *nulldelimiter)) {

with

  if (encrpass && *delimiter) {

This change can be done during commit as far as I am concerned. The rest
looks OK to me. Again, I am not really qualified to make the acceptance
decision in this area so you would have to wait for somebody else to do
that.


Cheers,

Alex.

_______________________________________________
squid-dev mailing list
squid-dev@lists.squid-cache.org
http://lists.squid-cache.org/listinfo/squid-dev

Reply via email to