> On Dec 22, 2015, at 8:42 PM, Brent Royal-Gordon <br...@architechies.com> 
> wrote:
> 
>> You shouldn’t have to say myProperty.lazy.backingStore.clear(), just 
>> myProperty.lazy.clear().
>> 
>> I don’t know where that leaves us :-)
> 
> I wonder if these should all just be flattened into the instance that owns 
> the property. So instead of saying foo.myProperty.lazy.clear(), you just say 
> foo.clearMyProperty() or some such. That approach isn't very principled, but 
> it *is* very convenient.

I agree that "myProperty.clear()" is very appealing, but it has the potential 
to be confusing when behavior methods are shadowed by members of the 
front-facing property. You'd still need a way to unambiguously refer to 
behavior methods when they're shadowed too.

-Joe
_______________________________________________
swift-evolution mailing list
swift-evolution@swift.org
https://lists.swift.org/mailman/listinfo/swift-evolution

Reply via email to