Indeed. Troy, in that case is my insertion of the new-line character going to break the searches? If one searches for a string that spans a new-line character in the filter, will the search pick up the white-space and be intelligent about searching for the newline character also? And what about the fact that DM says that <q> is not translated to "?
And if I wanted to take the current osisplain.cpp/.h and translate them into an output filter that would be more suitable for something like diatheke, what types of changes should be made to make that visible by the SWMgr? As was pointed out, if the main purpose of the current *plain.cpp files is to prepare the output for searching and not for display perhaps there should be a *plain_serach and *plain_display variants or some other such naming scheme? --Greg On 1/22/07, benjie <[EMAIL PROTECTED]> wrote: > On Mon, Jan 22, 2007 at 09:09:14PM -0700, Troy A. Griffitts wrote: > > Well, kindof. It's a matter of purpose. The purpose for a strip filter > > is to prepare the buffer for a search, e.g. stristr(StripText(), istr) > > > > for example, if one searches for a phrase, > > "streams of water that yield" > > > > It should hit on Psalm 1:3 > > > > He is like a tree > > planted by streams of water > > that yields its fruit in its season, > > and its leaf does not wither. > > In all that he does, he prospers. > > > > So, in conclusion, filters have different purposes. > > From: http://crosswire.org/svn/sword/trunk/include/swmodule.h > > > > virtual SWModule &AddRenderFilter(SWFilter *newfilter); > > virtual SWModule &AddEncodingFilter(SWFilter *newfilter); > > virtual SWModule &AddStripFilter(SWFilter *newfilter); > > virtual SWModule &AddRawFilter(SWFilter *newfilter); > > virtual SWModule &AddOptionFilter(SWOptionFilter *newfilter); > > So if we are interested in working with a plain text (ASCII) rendering > filter, we really need to write a new filter specifically for that. It > seems like that would be good for diatheke, which defaults to plain > output anyway. It wouldn't hurt for that output to be formatted a bit > better. > > -Benjie > > _______________________________________________ > sword-devel mailing list: sword-devel@crosswire.org > http://www.crosswire.org/mailman/listinfo/sword-devel > Instructions to unsubscribe/change your settings at above page > _______________________________________________ sword-devel mailing list: sword-devel@crosswire.org http://www.crosswire.org/mailman/listinfo/sword-devel Instructions to unsubscribe/change your settings at above page