On Wed, Sep 05, 2012 at 12:00:47PM -0500, Eric Haszlakiewicz wrote: > > > > Changing it to effective uid seems like a good plan. > > > > > > The change below fixes the test case. Is it safe to commit? > > > > It fixes the test case, but it is still wrong. This UID check > > needs to be implemented in the kauth listener (adding a specific > > case for this action if there's not one) not open-coded in the UFS code. > > Here's a (completely untested) patch that should do that.
...I don't think the check belongs in secmodel_suser.c, does it? Or is that the general dumping ground for standard Unix security semantics? -- David A. Holland [email protected]
