> The following aliases must also be provided, mapped to the appropriate 
> fixed-size primitives:
> 
> int     ufetch_char(const unsigned char *uaddr, unsigned char *valp);
> int     ufetch_short(const unsigned short *uaddr, unsigned short *valp);
> int     ufetch_int(const unsigned int *uaddr, unsigned int *valp);
> int     ufetch_long(const unsigned long *uaddr, unsigned long *valp);
I would have expected the argument of a funtion called xxx_short etc. 
to be a short etc., not an unsigned short etc.
Does it make sense to either make the argument char/short/int/long or 
change the name to ufetch_uXXX?

Reply via email to