On Tue, Sep 02, 2014 at 06:28:48AM -0400, Brad Smith wrote: > Add some feature flags and store in the softc the various max Jumbo frame > sizes > for the different generations of chips. No behavioral change. > > Tested with.. > > re0 at pci2 dev 0 function 0 "Realtek 8168" rev 0x03: RTL8168D/8111D (0x2800) > re0 at pci2 dev 0 function 0 "Realtek 8168" rev 0x0c: RTL8168G/8111G (0x4c00) > > OK?
This would be a much easier diff to read if you didn't change the names of a whole bunch of flags. > +#define RL_FLAG_HWIM 0x000000800 > +#define RL_FLAG_MACSLEEP 0x00000800 This is obviously wrong.
