On Jul 31, 2004, at 1:14 AM, Stas Bekman wrote:

so, have_foo is intuitive to be used anywhere in the code, and plan now will look like:

plan tests => 5, need_lwp, need_cgi, need_php;

I like this, but isn't it putting the onus of change on module owners and introducing the likelihood of unexpected test failures when module owners don't realize that they need to change their C<use> lines from have_* to need_*?

Perhaps we leave have_* with its current semantics, but then add "got_*" for the new semantics to be used anywhere in the code:

  # Always allow redirection.
  my $redir = got_lwp ? [qw(GET HEAD POST)] : 1;
  Apache::TestRequest::user_agent(reset => 1,
                                    requests_redirectable => $redir);

Regards,

David

Attachment: smime.p7s
Description: S/MIME cryptographic signature



Reply via email to