It seems JSR77 has been posted - I think everyone should read it.

What's important is the set of naming conventions for the managed
objects we expose - I strongly believe that we should use those
names wherever we provide the equivalent functionality.

For example ( on what is important for me ): 
- 'node' attribute - instead of jvmRoute 
- each tomcat instance in a distributed config must know 
about all other
- we should start exposing mbeans for JVM, WebModule and 
servlets using the naming conventions.

Of course, we should keep backward compat - but all old
attribute names should be eventually deprecated.

As I mentioned in the past, I'm not happy with XmlMapper/Digester
style used for configuration and I'm not happy with either 
server.xml format or with the way we save the config.

At this moment I have a very strong belief ( and it's getting 
stronger every day ) that we should adopt a configuration 
close to the JMX model, where every configurable object
is a named mbean. 

That means no more Interceptor/Context/Server/Valve/Listener/etc.

I also thing the configuration should be centered around a
class similar with RuntimeConfigurable on ant, where all the
 user settings are stored ( including ${props} ). Any 
configuration action that involves persistence should operate
on the RuntimeConfigurable, which should deal with saving
the config ( in a form as close as possible to the original 
user configuration ).

While I think XmlMapper/Digester are very powerfull tools, I think
tomcat5 should follow a model that is closer to ant - i.e. 
a set of patterns and a flatter configuration file. This has proven
to be easy and is well-understood ( even if I wrote a lot of 
code in xmlMapper, I do have troubles sometimes with it, and
nobody can claim it's as easy as ant tasks).

The question is: What do you think :-) ? 

Costin




--
To unsubscribe, e-mail:   <mailto:[EMAIL PROTECTED]>
For additional commands, e-mail: <mailto:[EMAIL PROTECTED]>

Reply via email to