"You said that it's for integers."

It is for integers. If I said, "it is only for integers" then I could see your point.

"I don't think explaining what it does is particularly useful to a beginner, anyway;"

The OP had a problem--a common problem--with these functions so they had to be mentioned. But the OP did not require an unnecessarily detailed explanation of the function.

"it's better to just say "don't use it"
Then that is what you should have done.

If you are advising people to use eval(raw_input()) instead of input() so that they can more clearly understand their own code and avoid mistakes, then just say that.

The miscommunication is that you write as though you are correcting me, when in reality you are just adding additional information.

Reply via email to