The following method names in domain-api and node-api include a
reference to either a domain or a node:
 SCADomain.addToDomainLevelComposite()
 SCADomain.removeFromDomainLevelComposite()
 SCADomain.getDomainLevelComposite()
 SCADomainFactory.createSCADomain()
 SCADomainFinder.getSCADomain()
 SCANode.getDomain()
 SCANode.addToDomainLevelComposite()
 SCANodeFactory.createSCANode()
 SCANodeFactory.createNodeWithComposite()

Of these 9 method names, 3 of them refer to "SCADomain" or "SCANode"
and 6 of them refer to plain "Domain" or "Node".

I would like to remove the "SCA" from the 3 method names that
include it.  Since the SCADomain* and SCANode* class names already
include "SCA" to disambiguate them from other kinds of node and
domain, I don't think there is a need to repeat the "SCA" in the
method names as well.

What do others think about this?

  Simon



---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to