Raymond Feng wrote:
Let me try to propose the following fix:

1) Add new interface such as PassByValueProvider (please help me with a better name) to the SPI.

public interface PassByValueProvider {
   /**
    * Indicate if the provider will enforce the pass-by-value semantics
    */
   boolean isPassByValueEnforced(Operation op);
}

[snip]

How about having the interceptors optionally implement that kind of interface instead of the providers?

--
Jean-Sebastien

---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to