On Wed, 25 Dec 2019 at 13:57, Heinrich Schuchardt <xypron.g...@gmx.de> wrote:
> On 12/24/19 4:54 PM, Sughosh Ganu wrote: > > Install the EFI_RNG_PROTOCOL implementation for it's subsequent use by > > the kernel for features like kaslr. > > > > Signed-off-by: Sughosh Ganu <sughosh.g...@linaro.org> > > --- > > include/efi_loader.h | 4 ++++ > > lib/efi_loader/efi_rng.c | 2 ++ > > lib/efi_loader/efi_root_node.c | 4 ++++ > > 3 files changed, 10 insertions(+) > > > > diff --git a/include/efi_loader.h b/include/efi_loader.h > > index bec7873..71996ec 100644 > > --- a/include/efi_loader.h > > +++ b/include/efi_loader.h > > @@ -130,6 +130,7 @@ extern const struct efi_hii_config_routing_protocol > efi_hii_config_routing; > > extern const struct efi_hii_config_access_protocol > efi_hii_config_access; > > extern const struct efi_hii_database_protocol efi_hii_database; > > extern const struct efi_hii_string_protocol efi_hii_string; > > +extern const struct efi_rng_protocol efi_rng_protocol_ops; > > Could we, please, call this variable efi_rng_protocol. > > Otherwise > > Reviewed-by: Heinrich Schuchardt <xypron.g...@gmx.de> > Will change the name of the symbol as suggested. Thanks. -sughosh