On 6/3/23 09:32, Peng Fan wrote:


On 6/2/2023 2:34 PM, Marek Vasut wrote:
Caution: This is an external email. Please take care when clicking links or opening attachments. When in doubt, report the message using the 'Report this email' button


On 6/2/23 08:45, Peng Fan (OSS) wrote:
From: Peng Fan <peng....@nxp.com>

i.MX8MN/P has Cortex-M7, i.MX93 has Cortex-M33, so use "M4" is a bit
misleading, so update the name of the macro

Signed-off-by: faqiang.zhu <faqiang....@nxp.com>
Signed-off-by: Peng Fan <peng....@nxp.com>
---
  arch/arm/include/asm/arch-imx8m/imx-regs.h |  2 +-
  arch/arm/include/asm/arch-mx6/imx-regs.h   |  2 +-
  arch/arm/include/asm/arch-mx7/imx-regs.h   |  2 +-
  arch/arm/mach-imx/imx9/imx_bootaux.c       |  6 +++---
  arch/arm/mach-imx/imx_bootaux.c            | 24 +++++++++++-----------
  board/kontron/sl-mx8mm/sl-mx8mm.c          |  2 +-
  board/kontron/sl-mx8mm/spl.c               |  2 +-
  board/technexion/pico-imx8mq/pico-imx8mq.c |  2 +-
  board/technexion/pico-imx8mq/spl.c         |  2 +-
  include/imx_sip.h                          |  6 +++---

I haven't had my coffee yet, so please pardon my ignorance, but which of
the boards that are being patched in this patch are iMX8MN/MP ?

I mean to use a generic name _MCU_ for i.MX8M* and i.MX93.

i.MX8MQ/M has M4
i.MX8MN/P has M7
i.MX93 has M33.

So the macro name _M4_ would be a bit misleading.

In that case:

'
Use "_MCU_" in place of both "_M4_" (i.MX8M/MQ which uses CortexM4) and "_M7_" (i.MX8MN/MP/93 which uses CortexM7) to simplify the naming.
'

Something like this would be clearer for the commit message. Adjust/expand/... as you wish.

Reply via email to