spinand_bind() binds a ubi_blk device at bind time. Now that "cmd:
ubi: create a ubi_blk device when attaching UBI" binds one generically
when UBI is attached -- with an identical result, only lazily and for
any flash type -- the SPI-NAND-specific eager call is redundant.

Drop it to avoid the duplicate code path (a ubi_blk is unusable before
UBI is attached anyway). The mtd_blk binding is kept: bare mtd_blk
access to SPI-NAND remains available for users who want it.

Signed-off-by: Daniel Golle <[email protected]>
---
 drivers/mtd/nand/spi/core.c | 3 ---
 1 file changed, 3 deletions(-)

diff --git a/drivers/mtd/nand/spi/core.c b/drivers/mtd/nand/spi/core.c
index 14af4264612..fb8ca0a787d 100644
--- a/drivers/mtd/nand/spi/core.c
+++ b/drivers/mtd/nand/spi/core.c
@@ -1654,9 +1654,6 @@ static int spinand_bind(struct udevice *dev)
                        if (ret)
                                return ret;
                }
-
-               if (CONFIG_IS_ENABLED(UBI_BLOCK))
-                       return ubi_bind(dev);
        }
 
        return 0;
-- 
2.55.0

Reply via email to