Beautifully said Mike!

When we switched to gradle, we dropped all "shortcut" tasks (ant targets)
and exposed users directly to the server, thereby combining and issuing
commands however the user desires.

The only shortcut tasks we left in are "testIntegration" and "loadDefault"
because we should be running them before applying every commit. So they are
there as a convenience but even then I think removing them is better.

If we remove them completely and instead get used to the below command
instead:

./gradlew cleanAll "ofbiz --load-data" "ofbiz --test"

Then we will be have to understand these commands and avoid shortcuts
altogether. Everyone would understand how to control the server and better
utilize it to fit their needs.

So my recommendation is to actually remove loadDefault and testIntegration.

On May 15, 2017 6:12 PM, "Mike" <mz4whee...@gmail.com> wrote:

gradlew "ofbiz --load-data readers=seed,seed-initial,ext,ext-demo"

Just leave it "as-is".  These are historical.  There is nothing gained but
more confusion and out-dating of existing documentation.


On Sun, May 14, 2017 at 10:34 PM, Paul Foxworthy <p...@cohsoft.com.au>
wrote:

> Hi all,
>
> At the risk of bikeshedding...
>
> The "data" is redundant. What else would you "load" but "data"?
>
> loadAll 1 (best)
> loadDefault 2
> loadAllData 3
> loadData 4 (worst)
>
> loadData should be infinity. It's meaningless.
>
> Cheers
>
> Paul Foxworthy
>
>
> On 13 May 2017 at 02:45, Paul Mandeltort <p...@marcospec.com> wrote:
>
> > Sorry, I’m being a jerk and not following your directions so feel free
to
> > ignore me, but some unsolicited advice :-)
> >
> > The proposed terms are still ambiguous. One of OFBiz’s biggest problems
> is
> > there’s a lot of shorthand and ambiguity which makes it really hard for
> > someone who occasionally digs in (like me) to figure out what’s going
on.
> >
> > So I’m going to suggest a bit more verbosity:
> >
> > Load-Data-All
> > Load-Data-Demo
> > Load-Data-Seed
> > Load-Data-Seed-Initial
> > Load-Data-External
> > Load-Data-External-Test
> > Load-Data-External-Demo
> >
> > to parallel the concepts in the readme. Then at least you can follow the
> > concepts through the pipeline. Now the naming of those data loading
tasks
> > is another function as they are still confusion (seed vs seed initial
> > description is confusing!).
> >
> >
> >
> > • seed: OFBiz and External Seed Data - to be maintained along with
source
> > and updated whenever a system deployment is updated
> > • seed-initial: OFBiz and External Seed Data - to be maintained along
> with
> > source like other seed data, but only loaded initially and not updated
> when
> > a system is updated except manually reviewing each line
> > • demo: OFBiz Only Demo Data
> > • ext: External General Data (custom)
> > • ext-test: External Test Data (custom)
> > • ext-demo: External Demo Data (custom)
> >
> > While I’m hardly an expert, I’ve always appreciated the pattern of
> > parameters following a “Verb-Noun-Adjective” format.  So in this case,
> Load
> > = Verb, Data = what, Adjective = what kind of data we’re loading.
> >
> > “ext” is also confusing, since it could be confused for “Extension”, but
> > that’s another discussion probably.
> >
> > If you’re a command-line warriors, you can add gradle autocomplete to
> Bash
> > and Zsh:
> > https://github.com/gradle/gradle-completion
> >
> > —P
> >
> > On May 12, 2017, 10:35 AM -0500, Jacques Le Roux <
> > jacques.le.r...@les7arts.com>, wrote:
> > > Hi,
> > >
> > > Following the discussion in this thread https://s.apache.org/9PBV we
> > agreed to change the name of the Gradle task which load demo and all
> data.
> > >
> > > Before Gradle it was load-demo. It's currently loadDefault and in the
> > discussion came loadAll, loadData and loadAllData.
> > >
> > > So I propose an informal vote, more a survey, to decide which name we
> > should use for this (important) task.
> > >
> > > Please vote by giving a weight to each of 4 propositions:
> > > loadDefault
> > > loadAll
> > > loadData
> > > loadAllData
> > >
> > > For instance, here is my choice
> > > loadDefault 4
> > > loadData 3
> > > loadAll 2
> > > loadAllData 1
> > > which means that I prefer loadAllData over loadAll, etc.
> > >
> > > So if we agree on the idea, we will pick the name with the smaller
> > cumulated number from participants
> > >
> > > Thanks
> > >
> > > Jacques
> > >
> >
>
>
>
> --
> Coherent Software Australia Pty Ltd
> PO Box 2773
> Cheltenham Vic 3192
> Australia
>
> Phone: +61 3 9585 6788
> Web: http://www.coherentsoftware.com.au/
> Email: i...@coherentsoftware.com.au
>

Reply via email to