The error referenced in that ticket was a documentation error, it has since
been fixed here
http://tapestry.apache.org/tapestry4.1/components/Upload.html .

The 10kb vs 10 (mil?) sounds pretty annoying. I think 10kb is the default
limit. The maxSize parameter is taken in units of "byte", so maybe it should
read "10,000" instead.

On 7/26/06, Murray Collingwood <[EMAIL PROTECTED]> wrote:

Hi all

I am using Tapestry 4.0.2

In the documentation on the 'Upload' component it mentions a default
upload size of
10,000,000 (10 million) and in brackets "10kb".  I'm not sure how that
works.  Which is
correct?

Assuming all my worst nightmares are coming true and that the limit is
10kb (although I
would much prefer a 10mb default limit) I went blindly ahead and added the
multipartdecoder
stuff to my hivemodule.xml file.  Alas it fails miserably.  All is not
lost though as I found a bug
had been reported and fixed as documented here...

http://issues.apache.org/jira/browse/TAPESTRY-995?page=all

Well, the bug is fixed for Tapestry 4.1 but there is little detail about
what the problem was and
whether it can be avoided in 4.0.2.

While I am new to Tapestry I am not new to the huge number of issues that
can result in
trying to upgrade one library in an application.

1. Is there a way of avoiding this bug in 4.0.2?

2. Is the default limit 10kb or 10mb?
PS Can the documentation be corrected for this please?

Cheers
mc


FOCUS Computing - web design
Mob: 0415 24 26 24
[EMAIL PROTECTED]
http://www.focus-computing.com.au




--
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.394 / Virus Database: 268.10.4/401 - Release Date: 26/07/2006


---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]




--
Jesse Kuhnert
Tacos/Tapestry, team member/developer

Open source based consulting work centered around
dojo/tapestry/tacos/hivemind.

Reply via email to