Component extension is one of my big preoccupation of my day work. That's
really a big question and there is no obvious answer.
I'm trying to explore ways with Tapestry 5 jQuery and I may blog on it in
the next weeks.

For example, I'm using workers to achieve what Benny Law said: adding mixins
to extend a component

And you have to add a bit of extra code per usage in the
> .tml (t:mixin="...").
>

Theses workers automatically adds mixins when transforming a class, i.e. :
http://github.com/got5/tapestry5-jquery/blob/master/src/main/java/org/got5/tapestry5/jquery/services/FormResourcesInclusionWorker.java

I'm also experimenting to create an abstract component class designed for
extension
http://github.com/got5/tapestry5-jquery/blob/master/src/main/java/org/got5/tapestry5/jquery/base/AbstractExtendableComponent.java

It is POC code but I think there are some ways to explore.


On Thu, May 13, 2010 at 11:34 PM, Steve Eynon <
steve.ey...@alienfactory.co.uk> wrote:

>  - a bit off topic I know but...
>
> I like "beforeRender()" and "afterRender()" for it's clear when they
> occur and why. Whereas beginRender() and endRender() sound like
> instructions - but onBeginRender() and onEndRender() on the other hand
> are also very clear, if not more so... Hmm...
>
>
> On 13 May 2010 17:12, Robert Zeigler <robe...@scazdl.org> wrote:
> >
> > * Note: I misnamed the method beforeRender in my earlier e-mail; should
> be beginRender.  It's always bugged me that's it's "beginRender" and
> "afterRender" instead of "beginRender" and "endRender" or "beforeRender" and
> "afterRender". :)
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscr...@tapestry.apache.org
> For additional commands, e-mail: users-h...@tapestry.apache.org
>
>

Reply via email to