> I'm very much against the current "static util" pattern that the > HeaderContributor object is headed. I would much rather have this > behavior moved into the appropriate class (ex: > JavascriptResource.headerContribution()) instead of bloating > HeaderContributor. this is how i designed the wicket FeedResource. > http://www.jroller.com/wireframe/entry/wicket_feedresource
I don't mind the factory pattern here (I started that code, so no surprise there). Instead of having to know a ton of classes, you just have to know this one. Also, we already have it, so extending it is not a big problem. I would be fine with adding this one as well if others don't object. Eelco --------------------------------------------------------------------- To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED]
