What is your usecase, why do you need to know this by looking at the generated 
HTML?

   -Tom


On 31.10.2012, at 18:24, eugenebalt <[email protected]> wrote:

> Is there a way to tell, just by looking at the rendered HTML, whether the
> component was a Wicket AjaxButton or a Wicket Button?
> 
> (All buttons may have various JavaScript appended to them, so you can't just
> see if onClick is empty or not. For instance, a Button might have a Confirm
> popup appended to it.)
> 
> But is there some kind of naming convention or a flag that could be reliably
> used to tell the difference?


---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to