https://codereview.chromium.org/883823002/diff/120001/src/ast.h
File src/ast.h (right):

https://codereview.chromium.org/883823002/diff/120001/src/ast.h#newcode3424
src/ast.h:3424: (name == ast_value_factory_->this_string())
Can we instead change from "bool is_this," to "Variable::Kind
variable_kind" ?

That way we avoid the load and comparison of this_string on what is a
relatively hot path of the parser -- perhaps a silly concern -- and we
preserve readability of callers.

https://codereview.chromium.org/883823002/diff/120001/src/parser.cc
File src/parser.cc (right):

https://codereview.chromium.org/883823002/diff/120001/src/parser.cc#newcode679
src/parser.cc:679: ast_value_factory()->this_string(),
here probably we will have to pass in Variable::THIS

https://codereview.chromium.org/883823002/diff/120001/src/parser.cc#newcode735
src/parser.cc:735: ? factory->NewVariableProxy(name, interface, pos)
instead of removing false, replace with Variable::NORMAL

https://codereview.chromium.org/883823002/diff/120001/src/scopes.h
File src/scopes.h (right):

https://codereview.chromium.org/883823002/diff/120001/src/scopes.h#newcode155
src/scopes.h:155: factory->NewVariableProxy(name, interface, position);
Please make this function take an additional Variable::Kind parameter,
and pass that parameter through to NewVariableProxy

https://codereview.chromium.org/883823002/

--
--
v8-dev mailing list
v8-dev@googlegroups.com
http://groups.google.com/group/v8-dev
--- You received this message because you are subscribed to the Google Groups "v8-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to v8-dev+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to