https://codereview.chromium.org/1109223004/diff/40001/src/compiler/js-typed-lowering.cc
File src/compiler/js-typed-lowering.cc (right):

https://codereview.chromium.org/1109223004/diff/40001/src/compiler/js-typed-lowering.cc#newcode336
src/compiler/js-typed-lowering.cc:336: if (r.OneInputIs(Type::String())
&& (!r.IsStrong() ||
On 2015/04/30 10:19:21, Michael Starzinger wrote:
suggestion: Would the following be easier to read/understand?

if ((r.OneInputIs(Type::String() && !r.IsStrong()) ||
     r.BothInputsAre(Type::String())) {
...
}

Ah, that's much nicer.

https://codereview.chromium.org/1109223004/

--
--
v8-dev mailing list
v8-dev@googlegroups.com
http://groups.google.com/group/v8-dev
--- You received this message because you are subscribed to the Google Groups "v8-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to v8-dev+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to