nice!

https://codereview.chromium.org/1161603006/diff/20001/src/heap/heap.cc
File src/heap/heap.cc (right):

https://codereview.chromium.org/1161603006/diff/20001/src/heap/heap.cc#newcode1294
src/heap/heap.cc:1294: fragmentation_percent >=
kLowFragmentationPercent;
Can we move this code into a function with a descriptive name?

https://codereview.chromium.org/1161603006/diff/20001/src/heap/heap.cc#newcode5448
src/heap/heap.cc:5448: ? 2
Let's make these two value also constants.

https://codereview.chromium.org/1161603006/diff/20001/src/heap/heap.h
File src/heap/heap.h (right):

https://codereview.chromium.org/1161603006/diff/20001/src/heap/heap.h#newcode1188
src/heap/heap.h:1188: // Allow slack of one page for each space.
I think this function should only return the real percent of
fragmentation. I would prefer passing in the slack as an "additional
live memory" parameter.
FLAG_never_compact should be applied outside as well. WDYT?

https://codereview.chromium.org/1161603006/

--
--
v8-dev mailing list
v8-dev@googlegroups.com
http://groups.google.com/group/v8-dev
--- You received this message because you are subscribed to the Google Groups "v8-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to v8-dev+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to