LGTM.

As discussed offline, we probably need to add guards in ..IC::Load/Store..
methods.


http://codereview.chromium.org/3047027/diff/1/2
File src/arm/stub-cache-arm.cc (right):

http://codereview.chromium.org/3047027/diff/1/2#newcode1258
src/arm/stub-cache-arm.cc:1258: __ Jump(Handle<Code>(Code::cast(code)),
RelocInfo::CODE_TARGET);
stylistic nit: maybe negative check:

if (!code->IsCode) return code;

or even if (code->IsFailure()) return code;

?

And maybe code should be renamed into something like result.

Feel free to ignore.

http://codereview.chromium.org/3047027/show

--
v8-dev mailing list
v8-dev@googlegroups.com
http://groups.google.com/group/v8-dev

Reply via email to