> - Renaming Map.remove(K key) in Map.unset(K key)
> - Renaming Map.contains(K key) in Map.has(K key)
> - Make Map<K, V> inherit from Collection<Map.Entry<K, V>>

I like unset. "has" is not different enough from "contains" for my
liking - I can see it being a source of future confusion ("What's the
difference between contains and has?!").
How about something that's clearly map-related, the way "unset" is?
"maps"? "has_set"?
(For a point of reference, ruby uses "has_key?" and "has_value?".)
_______________________________________________
Vala-list mailing list
Vala-list@gnome.org
http://mail.gnome.org/mailman/listinfo/vala-list

Reply via email to