On Thu, 4 Jun 2026 11:20:59 GMT, Viktor Klang <[email protected]> wrote:

>> Chen Liang has updated the pull request incrementally with one additional 
>> commit since the last revision:
>> 
>>   Message updated
>
> src/java.base/share/classes/java/io/ObjectStreamClass.java line 197:
> 
>> 195:     private MethodHandle deserializationCtr;
>> 196:     /** value deserialization method identified by {@link 
>> DeserializeConstructor}.*/
>> 197:     private Executable deserializeConstructor;
> 
> These two fields seems confusingly similarly named, possible to differentiate 
> the names a bit for clarity?

Also, can a type have both a `deserializationCtr` AND a 
`deserializeConstructor` or are they mutually exclusive?

-------------

PR Review Comment: 
https://git.openjdk.org/valhalla/pull/2326#discussion_r3355637130

Reply via email to