On Thu, 4 Jun 2026 12:12:16 GMT, Chen Liang <[email protected]> wrote:
>> Also, can a type have both a `deserializationCtr` AND a >> `deserializeConstructor` or are they mutually exclusive? > > I named this `deserializeConstructor` because this is for > `@DeserializeConstructor`. Maybe we can rename both the annotation and the > field "deserialization factory" or some other better name instead? I renamed this to `deserializeFactory` and the annotation to `@DeserializeFactory`. ------------- PR Review Comment: https://git.openjdk.org/valhalla/pull/2326#discussion_r3357060330
