On Tue, 5 May 2026 08:33:11 GMT, Casper Norrbin <[email protected]> wrote:

>> Hi everyone,
>> 
>> The `objArrayOop` gtest currently only tests reference arrays, but should 
>> also test on flat arrays. This is reflected by a `FIXME` at the top of the 
>> file. 
>> 
>> For this change I expanded the test to also cover flat arrays. The original 
>> tested options for ref arrays (mostly related to header size and layout) 
>> make less sense for a flattened array, so I instead picked more relevant 
>> options to test across. I also refactored the whole test so it becomes more 
>> readable. The actual data tested on remains untouched.
>> 
>> The jtreg runner was also missing a couple of configurations, had a bad 
>> gtest specifier, and had a flag misspelled, so I fixed all those as well.
>> 
>> Testing:
>> - Tier 1
>> 
>> ---------
>> - [x] I confirm that I make this contribution in accordance with the 
>> [OpenJDK Interim AI Policy](https://openjdk.org/legal/ai).
>
> Casper Norrbin has updated the pull request incrementally with one additional 
> commit since the last revision:
> 
>   removed unneeded modules

Marked as reviewed by jsjolen (no project role).

test/hotspot/gtest/oops/test_objArrayOop.cpp line 66:

> 64: }
> 65: 
> 66: static int make_lh(int payload_size_bytes, bool null_free) {

Better name please.

test/hotspot/jtreg/gtest/ObjArrayTests.java line 37:

> 35: 
> 36: /* @test id=no-coops
> 37:  * @summary Run object array size tests with compressed oops

*without*

test/hotspot/jtreg/gtest/ObjArrayTests.java line 49:

> 47: 
> 48: /* @test id=no-coops-medium-align
> 49:  * @summary Run object array size tests with compressed oops

*without*

test/hotspot/jtreg/gtest/ObjArrayTests.java line 61:

> 59: 
> 60: /* @test id=no-coops-large-align
> 61:  * @summary Run object array size tests with compressed oops

*without*

-------------

PR Review: 
https://git.openjdk.org/valhalla/pull/2383#pullrequestreview-4495648639
PR Review Comment: 
https://git.openjdk.org/valhalla/pull/2383#discussion_r3412043009
PR Review Comment: 
https://git.openjdk.org/valhalla/pull/2383#discussion_r3412016465
PR Review Comment: 
https://git.openjdk.org/valhalla/pull/2383#discussion_r3412013153
PR Review Comment: 
https://git.openjdk.org/valhalla/pull/2383#discussion_r3412014886

Reply via email to