A little review based on only reading wz28b.patch, not applying it:

## line 59: MAX_OAINFO_OBJS is a strange name, whether you added it or it was 
already in, this needs to be clear. Example:
-       BASE_OBJECT             *psObj[DROID_MAXWEAPS];
+       BASE_OBJECT             *psObj[MAX_OAINFO_OBJS];

## PRI_SLOT could just as easily be called PRIMARY_SLOT

## line 135: Can someone explain how you can get a reminder after devision by 
1? (should be %2)
+       //Random direction(left or right 30 degree's)
+       if (rand()%1 == 0)
+       {
+               angle += 30;
+               if (angle >= 360)
+               {
+                       angle -= 360;
+               }
+       }
+       else
+       {
+               angle -= 30;
+               if (angle < 0)
+               {
+                       angle += 360;
+               }
+       }

Also, why not write: angle = (angle-30)%360;

## line 184 + 285 + 989
+       /* Watermelon:if I am a multi-turret droid */
Just use the for loop, will act the same as the if when psDroid->numWeaps==1

## line 334: another scary name
+       DROID_OACTION_INFO oaInfo = {{NULL}};

## line 613: no need to add more commented out code to svn

## line 1748: why is it a factory anyway?
+                                               //skips rearm field,since it 
doesnt have assembly point

## line 2306: this is getting out of hand... anyone got a better idea?
+       //Watermelon orderX3,orderY3 for more complicated order...

## line 2541 + 5737: OMG... there has to be a better way...

## line 2665: I suggest we stop supporting compilers that don't support 
slotsX[MAX_REARM_SLOTS]
+       //Watermelon: 8 = MAX_REARM_SLOTS
+       UWORD                   slotsX[8];

## line 2693: make that ~0
+       SDWORD                          numMags; //Watermelon:number of 
magzines negative 1(-1) = infinite

## line 2701: You need to add a GAME_SAVE_V35 I'm afraid
+// Watermelon:added aDefaultRearm
 #define GAME_SAVE_V34 

## line 2742: ??? It's probably how pumpkin did it, but isn't there a better 
way?
+#define STRUCTURE_SAVE_V24 \
+       OBJECT_SAVE_V20; \

## line 3154: please explain the necessity of [i*5+4]
+                                               
psSaveStruct->RunwaysInfo[i*5+4] = psRearmField->runways[i].facing;

## line 3366: call it like this?: #define ONLY_SAME_TYPE_FACTORY_IN_LIST TRUE
+#define SEPARATE_LIST_TEST     1

## line 4237: Happy with being included in WZ?
+BOOL recvHappyJet(NETMSG *pMsg)

Looks like a lot of hard work, good job.

- Gerard



-----Original Message-----
From: [EMAIL PROTECTED] on behalf of The Watermelon
Sent: Mon 22-1-2007 21:47
To: Development list
Subject: [Warzone-dev] 500KB patch...
 
Couldnt separate them into smaller patches because the changes 'twisted'
alot...sorry for the huge patch.

Changes:(wz28b.patch)
1.Added 3 new propulsions that can be defined in propulsions.txt
(jet,helix,navy)
2.Added new structures:
rearmCentre(auto-rearm all units within its 'rearmRadius')
rearmField(a hybrid of rearm pad and factory,can build/support up to 8 'jet'
droids at one time)
3.Limited ammo and rearm.txt and added component ZNULLREARM to all templates
in templates.txt
note:1,2,3 might be partly unfinished/untested because they require a mod to
test and they dont affect the 'stock' wz
4.Fixed a bug which prevents the droids from removing 'died' targets for
auxiliary weapons.
5.Fixed some net message size count problems with vtol I made when adding
multiple weapons to vtol
6.Changed sinf/cosf to trig sin/cos lookup access functions trigSin and
trigCos for better performance
7.Changed vectorToAngle in move.c a bit to improve its efficiency('+= 360/4'
is weird and 'somevalue/180/2' is pointless too imo...)
8.Changed establishTargetHeight in projectile.c to use pIMD rather than
displayImd for structures to fix some weird height problems(hopefully)
9.Added a new function combFireLoc in combat.c,the function is used to
'attack location with x,y,z specified' without psTarget(like carpet bombing)
10.Added experimental test of a separate list in 'manufacture'
interface('#define SEPARATE_LIST_TEST' in hci.c,default on,comment it out to
use 'old' manufacture list)
old:when you click on a factory,it lists all of your factories in the
interface(cyborg,factory,vtol factory),which is odd...
test:when you click on a factory,it only lists all of your factories of the
same type you selected.
11.Added a hitbox bonus for indirect weapon's intended target.

Changes(wz28bData.patch)
1.Added rearm.txt(ZNULLREARM)
2.Added ZNULLREARM to all templates in templates.txt
3.Changed 'NULL' component to wz null entry style 'ZNULLSOMECOMP'
4.Added functions for rearmCentre and rearmField in functions.txt
5.Added dummy rearmfield and rearmcentre to structures.txt(because wz
a function depends on a structure...)
6.Changed wrf to deal with those changes.

<<winmail.dat>>

_______________________________________________
Warzone-dev mailing list
Warzone-dev@gna.org
https://mail.gna.org/listinfo/warzone-dev

Reply via email to