actually
protected void internaldestroy() { ondestroy(); }
@deprecated - use ondestroy instead
final void destroy() {}
void ondestroy() {}
-igor
On 6/20/07, Maurice Marrink <[EMAIL PROTECTED]> wrote:
as in ?
protected void internalDestroy()
{
...
destroy();
...
}
public final void destroy()
{
ondestroy();
}
public void ondestroy()
{
//do some cleanup here
}
bah, i'd rather have the rename. I have absolutly no problem with a
rename as long as it is announced on the mailing list. But i don't
think Martijn is going to allow that before 1.3.0 is out. But for my
part make the change whenever you want.
Maurice
On 6/20/07, Eelco Hillenius <[EMAIL PROTECTED]> wrote:
> On 6/20/07, Maurice Marrink <[EMAIL PROTECTED]> wrote:
> > Whatever makes you happy :)
> > I see Johan as has already made the change of putting callDestroyers
> > in internalDestroy.
> > However if you are going to rename that method (not sure if Martijn is
> > going to like that this late in the game). Please let us know since
> > those projects still on jdk 1.4 don't warn about missing override
> > methods.
>
> That's why we should leave the method in there as final and a TODO:
> remove after compat release.
>
> Eelco
>