+0
The Javadoc says: "A button that submits the form via ajax". And
the callback method is called onSubmit().
So even if you rename the class (which is a very costly operation
in a framework), it won't be sufficient to eradicate the term
"submit".
I understand that you want to streamline the name with Button, but
actually I would vote to rename Button to SubmitButton. I was
recently doing pair programming with a colleague, and we were
stupidly looking for "SubmitButton" and wondered why it was not
showing up. It was the obvious class name we thought...
--
Jean-Baptiste Quenot
aka John Banana Qwerty
http://caraldi.com/jbq/