On Tue, 30 Oct 2012 at 17:05:04 +0100, Rodolfo García Peñas (kix) wrote: > On 2012-10-30 16:42, Carlos R. Mafra wrote: > > > >Perhaps it's just me, but I can't really get what the function does > >from just reading its name: wAppIconFor(). I'm no native speaker, but > >the "For" suffix confuses me. I wonder if wAppIconOf() would be more > >"correct" -- ignoring the CamelCase issue :-) > > This is used in other functions. I don't have wmaker source here, > but the prototype is something like: > > wAppIconFor(WWindow *wwin) > > then you can read it as: > > AppIcon for wwindow :-)
Ok. > I am changing the camel case too, we can see the code modified :-) > > CamelCase: "Original" code > no_camel_case: New code :-P Yes, I know. But I want to avoid discussing this here. Iain wrote nices patches and chose those names, so let it be. Who writes the code decides, as a first approximation. Knowing about the non_camel_case preferrence of wmaker.git is a plus, not a condition :-) I just wanted to raise the point that having a comment on top of the function explaining its purpose in life (one or two lines is often enough). The patches are going to be applied, they are very cool and have a lot of potential. -- To unsubscribe, send mail to [email protected].
