On 6/8/06, Lonny Eachus <[EMAIL PROTECTED]> wrote:
After considering this carefully, I would argue that this is a good idea, but it should really be a different method with a different name.

1) Adding a non-optional parameter to the "exists?" method call would break existing code.

2) This retry loop is really more of a "wait_for()" method for elements, without having to instantiate the element first. This is a great idea . . . but the purpose is different than that of merely testing for existence.

To me, those two things practically scream "new method".

I'm confused. The proposal isn't to change the exists? method, but rather the other methods.

If you want a new name (for whatever method), please suggest one.

Specifically, I propose that where you currently do this:
while not ($ie.link(:text,"Second").exists?)
  sleep 0.5
end
$ie.link(:text,"Second").click
You would instead just do this
$ie.link(:text,"Second").click
And you would implicitly get the polling behavior that had been explicit. The proposal is to change all the element methods, except (perhaps) "exists?".

It seems to me that "exists?" is a separate case. We should consider it separately.

Do we have agreement on the usefulness of the proposal, if no change is made to exists?

Bret
_______________________________________________
Wtr-general mailing list
Wtr-general@rubyforge.org
http://rubyforge.org/mailman/listinfo/wtr-general

Reply via email to