On 5/22/20 1:34 PM, Stefano Stabellini wrote: > On Thu, 21 May 2020, Boris Ostrovsky wrote: >> On 5/20/20 7:45 PM, Stefano Stabellini wrote: >>> From: Stefano Stabellini <stefano.stabell...@xilinx.com> >>> >>> Call dma_to_phys in is_xen_swiotlb_buffer. >>> Call phys_to_dma in xen_phys_to_bus. >>> Call dma_to_phys in xen_bus_to_phys. >>> >>> Everything is taken care of by these changes except for >>> xen_swiotlb_alloc_coherent and xen_swiotlb_free_coherent, which need a >>> few explicit phys_to_dma/dma_to_phys calls. >>> >>> Signed-off-by: Stefano Stabellini <stefano.stabell...@xilinx.com> >>> --- >>> drivers/xen/swiotlb-xen.c | 20 ++++++++++++-------- >>> 1 file changed, 12 insertions(+), 8 deletions(-) >>> >>> diff --git a/drivers/xen/swiotlb-xen.c b/drivers/xen/swiotlb-xen.c >>> index c50448fd9b75..d011c4c7aa72 100644 >>> --- a/drivers/xen/swiotlb-xen.c >>> +++ b/drivers/xen/swiotlb-xen.c >>> @@ -64,14 +64,16 @@ static inline dma_addr_t xen_phys_to_bus(struct device >>> *dev, phys_addr_t paddr) >>> >>> dma |= paddr & ~XEN_PAGE_MASK; >>> >>> - return dma; >>> + return phys_to_dma(dev, dma); >>> } >>> >>> -static inline phys_addr_t xen_bus_to_phys(struct device *dev, dma_addr_t >>> baddr) >>> +static inline phys_addr_t xen_bus_to_phys(struct device *dev, >>> + dma_addr_t dma_addr) >> >> Since now dma address != bus address this is no longer >> xen_bus_to_phys(). (And I guess the same is rue for xen_phys_to_bus()). > Should I rename them to xen_dma_to_phys and xen_phys_to_dma?
Yes, please. -boris