[ 
https://issues.apache.org/jira/browse/YARN-4511?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16226021#comment-16226021
 ] 

Haibo Chen commented on YARN-4511:
----------------------------------

Filed YARN-7337 for SchedulerNodeReport changes because I think there is more 
work to do there.

Uploaded the patch to include the following changes:
1) remove duplicate isDebugEnabled()
2) replace assert statements with throw YarnRuntimeExceptions
3) rename guaranteedContainerResourceReleased() to guaranteedContainerReleased,
 include all necessary updates. Similarly for 
opportunisticContainerResourceReleased(),
 opportunisticContainerResourceAllocated(), 
guaranteedContainerResourceAllocated()
4) replace containerAllocated(resource, allocatedResourceOpportunistic) with
if (containerAllocated(resource, allocatedResourceOpportunistic)) {
     // nothing else to do
} 
to make it consistent with guaranteed container allocation.


> Common scheduler changes supporting scheduler-specific implementations
> ----------------------------------------------------------------------
>
>                 Key: YARN-4511
>                 URL: https://issues.apache.org/jira/browse/YARN-4511
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Wangda Tan
>            Assignee: Haibo Chen
>         Attachments: YARN-4511-YARN-1011.00.patch, 
> YARN-4511-YARN-1011.01.patch, YARN-4511-YARN-1011.02.patch, 
> YARN-4511-YARN-1011.03.patch, YARN-4511-YARN-1011.04.patch, 
> YARN-4511-YARN-1011.05.patch, YARN-4511-YARN-1011.06.patch, 
> YARN-4511-YARN-1011.07.patch, YARN-4511-YARN-1011.08.patch, 
> YARN-4511-YARN-1011.09.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to