[ 
https://issues.apache.org/jira/browse/YARN-10043?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17025899#comment-17025899
 ] 

Peter Bacsko edited comment on YARN-10043 at 1/29/20 2:06 PM:
--------------------------------------------------------------

Some comments from me:
1. Nit: Pay attention to missing white spaces, like {{if(res) == 0}} (after 
"if")

2. {{compareDemand()}} can be simplified:

{noformat}
return (int) Math.signum(demand2 - demand1);
{noformat}

3. {{testOrderingUsingAppSubmitTime()}} has multiple asserts. I'd prefer having 
separate test cases for better readability. Examples:
 * testOrderingWithoutUsedAndPendingResources
 * testOrderingWithUsedAndPendingResources
 * testOrderingWithSubmissionTime

4. Same applies to {{testOrderingUsingAppDemand()}}. Could be split up like:
* testOrderingWithZeroDemand
* testOrderingWithSameStartTimeDifferentDemand
* Also, "//No changes, equal" part is the same as in 
{{testOrderingUsingAppSubmitTime()}}


was (Author: pbacsko):
Some comments from me:
1. Nit: Pay attention to missing white spaces, like {{if(res) == 0}} (after 
"if")

2. {{compareDemand()}} can be simplified:

{noformat}
return (int) Math.signum(demand2 - demand1);
{noformat}

3. {{testOrderingUsingAppSubmitTime()}} has multiple asserts. I'd prefer having 
separate test cases for better readability. Examples:
 * testOrderingWithoutUsedAndPendingResources
 * testOrderingWithUsedAndPendingResource
 * testOrderingWithSubmissionTime

4. Same applies to {{testOrderingUsingAppDemand()}}. Could be split up like:
* testOrderingWithZeroDemand
* testOrderingWithSameStartTimeDifferentDemand
* Also, "//No changes, equal" part is the same as in 
{{testOrderingUsingAppSubmitTime()}}

> FairOrderingPolicy Improvements
> -------------------------------
>
>                 Key: YARN-10043
>                 URL: https://issues.apache.org/jira/browse/YARN-10043
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Manikandan R
>            Assignee: Manikandan R
>            Priority: Major
>         Attachments: YARN-10043.001.patch, YARN-10043.002.patch
>
>
> FairOrderingPolicy can be improved by using some of the approaches (only 
> relevant) implemented in FairSharePolicy of FS. This improvement has 
> significance in FS to CS migration context.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to