[ 
https://issues.apache.org/jira/browse/YARN-9995?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17063148#comment-17063148
 ] 

Bilwa S T commented on YARN-9995:
---------------------------------

Hi [~snemeth] do u mean something like below ? 
{quote}<R> Object getValues(SchedConfUpdateInfo schedUpdateInfo,
         String methodname) {
     Method method = null;
     try {
         method = SchedConfUpdateInfo.class.getMethod(methodname);
          return method.invoke(schedUpdateInfo);
      } catch (Exception ex) {
         ex.printStackTrace();
      }
     return null;
 }
{quote}
 

> Code cleanup in TestSchedConfCLI
> --------------------------------
>
>                 Key: YARN-9995
>                 URL: https://issues.apache.org/jira/browse/YARN-9995
>             Project: Hadoop YARN
>          Issue Type: Improvement
>            Reporter: Szilard Nemeth
>            Assignee: Bilwa S T
>            Priority: Minor
>
> Some tests are too verbose: 
> - add / delete / remove queues testcases: Creating SchedConfUpdateInfo 
> instances could be simplified with a helper method or something like that.
> - Some fields can be converted to local variables: sysOutStream, sysOut, 
> sysErr, csConf
> - Any additional cleanup



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org

Reply via email to