> I don't doubt that there is a use for the current implementation.  What
I'm
> saying is that calling it "value_type" is wrong because that term is used
> already in standard C++, and with a different meaning.
> call_traits::value_type should be like iterator_traits::value_type -- a
> non-const, non-reference that can be used to store temporary variables in
> algorithms and whatnot.  I suspect that this is the more common usage
> scenario (<-- blind asseriton), and it is the behavior people would
expect.

It depends, compressed_pair relies on the current behaviour: is you create
compressed_pair<int&, int&> then you would want it to store references
wouldn't you?

Using call_traits<remove_reference<T>::type>value_type is not so hard IMO.

John


_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost

Reply via email to