Hello,
Since this patch, /dev/zero can't be mmap-ed... See attached testcase.
This is making apache fail to start on darnassus.
And indeed, trivfs_S_io_map has disappeared, but netfs_S_io_map was not
introduced.
Also, ls -l /dev/zero returns
ls: reading directory '/dev/zero': Not a directory
I guess it should be fixed into not showing the directory type when
there is not partition table.
Samuel
#include <sys/mman.h>
#include <fcntl.h>
#include <stdio.h>
#include <error.h>
#include <errno.h>
int main(void) {
int fd = open("/dev/zero", O_RDONLY);
char *c = mmap(NULL, 4096*16, PROT_READ|PROT_WRITE, MAP_PRIVATE, fd, 0);
if (c == MAP_FAILED)
error(1, errno, "mmap");
printf("%p\n", c);
return 0;
}