Samuel Thibault, le lun. 05 oct. 2026 23:37:13 +0200, a ecrit:
> Since this patch, /dev/zero can't be mmap-ed... See attached testcase.
> This is making apache fail to start on darnassus.
> 
> And indeed, trivfs_S_io_map has disappeared, but netfs_S_io_map was not
> introduced.
> 
> Also, ls -l /dev/zero returns 
> 
> ls: reading directory '/dev/zero': Not a directory
> 
> I guess it should be fixed into not showing the directory type when
> there is not partition table.

Also,

€ sudo ls /dev/sd0/ -l
total 1
b--------- 1 root root 86, 77 oct.   5 21:39 1
b--------- 1 root root 86, 77 oct.   5 21:39 2

It's missing some permissions :)

Samuel

Reply via email to